20th May 2023

New York Datacenter Power Incident - New York Datacenter

We are aware that there is currently a partial network outage affecting multiple of host-nodes of the New York data center location.

Our datacenter facility team is currently looking into this further. We will have more information on this shortly.

UPDATE: This looks to be a power related event. More details to come.

UPDATE: As of now, power for approximately half of the devices facility wide is restored. The datacenter facility is currently investigating to discover what exactly went wrong. Utility power went down and did not fail over to the generators as was expected for a seamless transition of power. We will update when we have more information as to the cause for the outage and once power has been fully restored.

UPDATE: Progress is being made. Power is restored to approximately 80% of affected devices. We are diligently working on the remaining, and will update once more information is available.

UPDATE: Power is restored to approximately 95% of affected devices. We are diligently working on the remaining 5%, and will update once more information is available.

UPDATE: Excellent progress is being made. We're almost there... just a few more physical devices that need to be worked on. We hope to have this incident fully closed out & resolved within the next hour.

UPDATE: The power incident is now fully resolved facility-wide. A RFO from our facility partner will be available in the next few business days. If you are still experiencing any issues with your services hosted in New York, please feel free to open a support ticket and we will assist you further.