18th October 2021

Amsterdam Datacenter Outage - AMS104KVM (One KVM VPS Node in Amsterdam)

We are aware that AMS104KVM (one KVM VPS node in Amsterdam) is experiencing connectivity issues.

We are currently looking into this node further and will update this incident with additional information shortly.

UPDATE: This is related to a faulty RAM DIMM on the physical host node, we are currently troubleshooting this and in the meantime, have submitted a request with facility hands for RAM replacement. We will update this incident with more information as we progress further with AMS104KVM. Thank you for your patience.

UPDATE: This is now resolved and all VM's are now responsive again. If you are still experiencing any issues please open a support ticket and we'd be happy to assist.