28th November 2021

Seattle Datacenter SEA107KVM(One KVM VPS Node in Seattle)

We are aware that SEA107KVM one KVM VPS node is currently experiencing issues.

We are currently looking into this node further and will provide additional updates on this matter once we have more information.

UPDATE: We are still investigating the issue with this node.

UPDATE: This node is back online, we will continue monitoring it. If you have any questions or if you are experiencing any issues, please open a support ticket.