To help you better interpret the information presented here, please keep the following in mind:

Defining Hypervisors and Nodes

Interpreting Status Meanings

For VPS Customers

Important Notes

7th May 2024

New York Datacenter Outage - 7950XNY300

We are aware that 7950XNY300 is currently experiencing connectivity issues. We are currently looking into this node further and will provide additional updates on this matter once we have more information.

UPDATE: We apologize for the continued issues with 7950XNY300. Our on-site datacenter team is currently performing a thorough investigation on this server physically, with the goal to stabilize this node and to prevent future occurrences of this issue. Rest assured, we will do what is needed to take care of this issue permanently. We appreciate your patience and will have this back online shortly!

UPDATE: This is now resolved. If you are still experiencing any issues please open a support ticket and we'd be happy to assist.