We are aware that two of our cabinets in our Dallas location are currently experiencing issues.
We are currently looking into this further with our datacenter partner, and will provide additional updates on this matter once we have more information.
UPDATE: We have one of the cabinets fully back online, we will provide an additional update shortly.
UPDATE: This is now resolved. If you are still experiencing any issues please open a support ticket and we'd be happy to assist.