5th May 2025

Seattle Datacenter OUTAGE - SEA118KVM,SEA119KVM and SEA143KVM

We are aware that SEA118KVM, SEA119KVM, and SEA143KVM are currently experiencing connectivity issues.

We are currently looking into these nodes further and will provide additional updates on this matter once we have more information.

UPDATE: These nodes SEA118KVM,SEA119KVM are back online and resolved. If you are still experiencing any issues, please open a support ticket and we'd be happy to assist.

UPDATE: This node SEA143KVM is also back online and is now resolved. If you are still experiencing any issues please open a support ticket and we'd be happy to assist.