23rd February 2022

Seattle Datacenter Outage - SEA100KVM (One KVM VPS Node in Seattle)

We are aware that SEA100KVM is currently experiencing connectivity issues. We are currently looking into this node further and will provide additional updates on this matter once we have more information.

UPDATE: The recent connectivity issues with SEA100KVM have been narrowed down to a bad top of rack switch which will need to be replaced.

On-site technicians are currently working on replacing the Top of Rack Switch. We will have this back online and resolved shortly.

UPDATE: This is now resolved. If you are still experiencing any issues please open a support ticket and we'd be happy to assist.