17th May 2025

Seattle Datacenter OUTAGE - SEA117KVM

We are aware that SEA117KVM is currently experiencing connectivity issues. We are currently looking into this node further and will provide additional updates on this matter once we have more information.

UPDATE: We have identified the issue with SEA117KVM to a faulty RAM DIMM module. Our on-site datacenter engineers are actively working to replace this.

UPDATE: We are still working on the issue with node SEA117KVM. We have run into additional hardware complications and this is actively being investigated.

UPDATE: This is now resolved. If you are still experiencing any issues please open a support ticket and we'd be happy to assist.