2nd October 2025

Connectivity Issues – US-West (Cogent)

We are currently observing less-than-ideal connectivity in our US-West region, specifically impacting routes traversing Cogent in locations such as San Jose and Seattle. Customers in these regions, or whose traffic paths must pass through these areas, may experience degraded connectivity or intermittent packet loss.

For context, Cogent Communications is a major global Internet Service Provider (ISP) and one of the largest Tier 1 backbone carriers. Tier 1 providers like Cogent form part of the “core” of the Internet, interconnecting with other large networks worldwide. Because so much Internet traffic ultimately depends on these backbones, an issue with a Tier 1 provider can have ripple effects — not just for RackNerd, but for many providers and external services across the Internet that rely on Cogent either directly or indirectly. Other carriers that peer with Cogent may also be affected, which broadens the scope of impact.

Please also note: even if your services are not hosted in San Jose or Seattle, you may still observe intermittent connectivity issues. This is because a large portion of global Internet backbone traffic flows through the US West Coast, and certain routes are inevitably influenced by these disruptions. In short, this is a broader Internet connectivity problem rather than something specific to our infrastructure.

Our upstream providers are actively engaged and working on implementing a workaround solution, while we await Cogent’s team to apply permanent fixes on their side.

We will continue to provide updates here as more information becomes available.

Thank you for your patience and understanding.

UPDATE 7:55 PM Pacific: It appears Cogent has updated their own status page as well at https://ecogent.cogentco.com/network-status --

"Customers with traffic traversing the Cogent network backbone in the midwestern United States region may see latency, packet loss, or other issues. The Cogent NOC is currently investigating. There is no ETR at this time. The master case for this issue is HD305477725."

UPDATE 9:42 PM Pacific: While Cogent’s own status page has not yet reported any change to their master case, we have observed a significant improvement in connectivity. At this time, the majority of earlier affected routes are operating normally again.

We will continue to closely monitor the situation and provide further updates as needed.

UPDATE 10:00 PM Pacific: Connectivity has remained mostly stable for some time now, and we are officially downgrading this incident to “Watching” status on our end. While Cogent’s own status page has not yet reflected any change, from what we have observed, the majority of routes are now resolved and operating normally.

We will continue to monitor closely. Please note that while services are largely restored, there is still a possibility of intermittent issues until Cogent fully resolves the root cause. This incident will remain open in “Watching” status and will be considered officially closed once Cogent confirms resolution on their side.

UPDATE: Cogent has officially updated this as resolved on their side. This incident is now going to be considered fully resolved.