15th October 2025

Amsterdam Datacenter Scheduled Maintenance - Amsterdam Datacenter

As previously communicated to affected customers via email back on October 2nd, Equinix will be performing a scheduled maintenance event in Amsterdam today between the period: Thursday, October 16th, 2025 – 05:00 to 17:00 UTC.

Services hosted in Amsterdam may be unavailable during this period. Once Equinix has completed their work (which we are hopeful will be before the maintenance window is over), services will be restored as quickly as possible.

Our team will be closely monitoring throughout this process and doing everything we can to minimize disruption.

We will update this status incident once the maintenance window is fully completed.

UPDATE: We've been told that this maintenance is now being wrapped up, we should have services back online shortly.

UPDATE: We are in the process of re-energizing our cabinets.

UPDATE 16:49 UTC: At this time, all Amsterdam nodes are back online and fully operational, with the exception of AMS106KVM. We are awaiting confirmation from the on-site team to verify that AMS106KVM has been powered on correctly. Further updates will be provided regarding this node as soon as we have more information.

UPDATE: All Amsterdam nodes are back online, including 'AMS106KVM'. If you are still experiencing any issues please open a support ticket and we'd be happy to assist.