19th April 2026

New York Datacenter OUTAGE - 7950XNY204

We are aware that 7950XNY204 is currently experiencing issues.

We are currently looking into this node further and will provide additional updates on this matter once we have more information.

UPDATE: We are still actively troubleshooting the issues with 7950XNY204 and greatly appreciate your continued patience. Customers with VMs hosted on this node may continue to experience intermittent connectivity until the matter is fully resolved.

Our team is actively working alongside on-site datacenter staff to further investigate and resolve this issue, as physical intervention is required. We will continue to provide updates here as new information becomes available, or once this matter has been fully resolved.

UPDATE: This is now resolved. If you are still experiencing any issues please open a support ticket and we'd be happy to assist.

UPDATE: We are seeing a recurrence of the previous issues with 7950XNY204. Our team is investigating this further.

UPDATE: We have replaced several hardware components of the 7950XNY204 node, including the motherboard and all DIMM modules, which we believe will serve as a permanent resolution to the recurring issues previously observed. The node has been brought back online and is currently being closely monitored to ensure stability and consistent performance.

At this time, services should be operating normally. If you continue to experience any issues, please do not hesitate to open a support ticket so our team can assist you promptly. We appreciate your continued patience and understanding throughout this matter.