26th December 2020

Los Angeles DC-02 Fiber3

Fiber3 (one shared/reseller hosting server in Los Angeles) is currently experiencing a network related outage. We are currently investigating this matter and will update this incident with more details as it becomes available.

Update #1: This appears to be a partial network outage affecting connectivity to the server when connecting from certain regions - this has been escalated to our upstream at this time.

Update #2: Network engineers upstream are actively engaged and working on the reported issue. Additional updates to follow shortly.

Update #3: Connectivity is now restored. Please contact our Support Department if you are still experiencing any issues after this time. More details and a RFO (reason for outage) will be updated within this incident within the next 72 hours.