We are aware that LAXSSD105DC03 (one KVM VPS node in Los Angeles) is currently experiencing issues.
We are currently looking into this node further and will provide additional updates on this matter once we have more information.
UPDATE: We have exhausted all available remote troubleshooting and recovery options without success. As a result, we are now awaiting on-site facility technicians to physically inspect and bench the server.
Because physical intervention is required, resolution may take some additional time. However, we anticipate fully resolving the issue within the next 24 hours or sooner. We sincerely appreciate your patience and will provide further updates as soon as additional information becomes available.
UPDATE: This is now resolved. If you are still experiencing any issues please open a support ticket and we'd be happy to assist.