20th August 2026

Los Angeles Datacenter OUTAGE - LAXSSD881DC03

We are aware that LAXSSD881DC03 is currently experiencing issues.

We are currently looking into this node further and will provide additional updates on this matter once we have more information.

UPDATE: Our initial investigation indicates that the issue affecting LAXSSD881DC03 will require additional hardware related troubleshooting and physical intervention by the LA remote-hands team. As a result, resolution may take additional time.

Please be assured that customer data remains safe. We will continue providing updates as more information becomes available.

UPDATE: This is now resolved. If you are still experiencing any issues please open a support ticket and we'd be happy to assist.