As previously communicated to our customers via email on September 16, today we will be upgrading the software that powers our VPS control panel, along with underlying hardware infrastructure to better support our continued growth and increasing demand. These upgrades will take place according to the following maintenance schedule:
Date: September 22, 2026
Start Time: 9:00 AM Pacific Time (16:00 UTC)
End Time: 1:00 PM Pacific Time (20:00 UTC)
During this maintenance window, the VPS control panel will be temporarily unavailable. There may also be intermittent access to the RackNerd Client Area during this period.
Your services will remain online throughout the maintenance, and there will be no impact to your services. Websites, applications, SSH access, and other services running on your server will not be affected.
While the control panel is unavailable, you will temporarily be unable to perform panel-based management actions, including rebooting or power cycling your VPS, reinstalling the operating system, or managing other VPS settings. If your VPS remains reachable through SSH, you may continue managing it normally and can initiate a reboot from within the operating system if needed.
Due to intermittent Client Area availability, customer support will be available by email during the maintenance window. If you require assistance at any point during the maintenance window mentioned above, please contact us directly at [email protected]. Our team will continue monitoring this inbox and responding to requests throughout the maintenance period.
No action is required on your part, as there will be no downtime to your services. Full access to the VPS control panel and RackNerd Client Area is expected to be restored before the end of the maintenance window. We will update this status incident once maintenance is about to commence.
UPDATE 9:00 AM PT: Maintenance is about to commence. We will update this status incident once completed.
UPDATE 9:20 AM PT: Updates are actively in progress and everything is progressing well so far. Customer infrastructure remains unaffected.
We will update once additional information or progress is available to share.
UPDATE 12:19 PM PT: Maintenance is now complete.
