We are aware that DAL119KVM is currently offline.
We are currently looking into this node further and will provide additional updates on this matter once we have more information.
UPDATE: Because of the recent numerous outages on this particular host node, we believe there may be a PSU related issue (perhaps, PSU that is going bad) on this physical host node which is causing an unstable power connection to this node. On-site datacenter technicians are checking further and we will replace the PSU if necessary.
UPDATE: On-site datacenter technicians are aware and actively working on this node.
UPDATE: This is now resolved. If you are still experiencing any issues please open a support ticket and we'd be happy to assist.