We are aware that CHIRYZEN103 is currently experiencing issues.
We are currently looking into this node further and will provide additional updates on this matter once we have more information.
UPDATE: This particular host node appears to be experiencing some physical hardware related issues, at this time we are submitting a request with the datacenter technical team to further investigate.
UPDATE: This is now resolved. If you are still experiencing any issues please open a support ticket and we'd be happy to assist.