22nd November 2022

[SCHEDULED MAINTENANCE] RackNerd Website and Client Area

RackNerd's website will be undergoing scheduled maintenance at the following timeframe:

Maintenance Start Date: November 23, 2022

Maintenance Start Time: 11:00 AM PST

Maintenance End Time: 11:30 AM PST

Scope of Work: We will be upgrading our underlying infrastructure that empowers our website (racknerd.com) and client portal (my.racknerd.com) due to the surge of traffic and demand. Our website and client portal features may be unavailable for up to 30 minutes during this time.

Client services will not be affected, and will remain online.

If you require assistance during this maintenance timeframe, please e-mail us at [email protected], call us at 888-881-NERD, or submit a support ticket in our client area after the maintenance window is completed.

We will be moving this status incident to active once the maintenance window commences.

UPDATE: This maintenance is about to commence. We will share another update once this is completed.

UPDATE #2: This maintenance is now completed, and our website and client portal is now available again. We will be closing out this status incident as resolved now. Feel free to open a support ticket if you have any questions.