5th December 2022

New York Datacenter Emergency Maintenance on NYRN135KVM

As communicated via e-mail to affected customers, we have determined that the RAID array on NYRN135KVM is in a degraded state. We are taking NYRN135KVM offline for a brief moment to conduct an emergency drive replacement.

We will update this status incident once resolved.

UPDATE: It appears that this requires further troubleshooting, thank you for your patience while we continue to look into this.

UPDATE: Our efforts to allow the RAID controller to rebuild in a live environment were unsuccessful. It is most safe to rebuild this RAID array offline. We are taking the server down to our work bench now, and will allow time for the RAID array to rebuild. This process could take several hours. We apologize for the unexpected delay and will share updates once available.

UPDATE: The RAID rebuild is currently at 19%.

UPDATE: The server is back online on a degraded RAID array, and our attempts to rebuild the RAID array in a timely fashion was not successful due to corrupt RAID metadata. However, since we utilize RAID-10 we were still able to get the server online. To minimize further impact and downtime, we believe the best course of action is to bring this server back online and then migrate VM's on this node one by one over to another host node. This will be a seamless migration and you will not experience any IP changes, and all data will be migrated in place. We will be working on these migrations starting shortly and we anticipate all migrations being completed within the next 24-48 hours.

UPDATE: Albeit a degraded RAID status, we are currently working towards migrating VM's to another healthy host node. Your data and VPS IP address will remain intact, though you may notice up to 30 minutes of downtime while your VM migrates. You will know the migration is done by logging into the SolusVM VPS Control Panel, which will tell you what node your VPS is on. Once it says a node name that is not NYRN135KVM, it will mean that your VPS has been successfully migrated and booted up to the new host node already.

If any action is required from your end, you will receive an e-mail notification from us.

We will be closing this incident out but we are working on migrations, if anyone has any questions regarding the migration please feel free to reach out to us.