29th January 2023

Seattle Datacenter Network Outage - Seattle Datacenter Location

We are aware that there is a partial network outage impacting about a dozen VPS nodes in our Seattle location.

We are currently looking into this incident further with our upstream provider, and will provide additional updates on this matter once we have more information.

UPDATE: Our upstream provider’s networking team is actively aware and working on this issue. It appears to be an issue related to border routers. We will update this status incident again once additional progress has been made.

UPDATE: This is now resolved. If you are still experiencing any issues please open a support ticket and we'd be happy to assist.